Перейти к содержимому


- - - - -

Не запоминается состояние слоев подключенной внешней ссылке


Сообщений в теме: 7

#1 SYB75

    Участник

  • Пользователи
  • PipPipPip
  • 87 сообщений
  • Пол:Мужчина
  • Город:Самара

Отправлено 31 Май 2018 - 15:18

Здравствуйте!
Есть файл с подгруженными внешними ссылками.
Так вот.
Открываю документ, отключаю несколько слоев, сохраняю.
Закрываю документ.
Снова открываю этот документ, а слои остались включенными.
Кто-нибудь сталкивался с таким?

#2 Kreator

    Активист

  • Пользователи
  • PipPipPipPip
  • 686 сообщений
  • Пол:Мужчина
  • Город:Краснодар

Отправлено 31 Май 2018 - 15:36

Кажется, так было всегда. Не помню деталей, но по-моему, лампочки сбрасываются при изменении файла-ссылки. Но это не точно :) Я от этой практики сразу и ушёл.
Слои же Вы выключаете в файлах-ссылках?
Пробовали отключать слои не лампочкой, а солнцем (заморозить на всех ВЭ)?
Полховский А.В. Проектирование железнодорожных путей
nanoCAD Plus 10.1.4468.1506; MultiCAD.NET; Печатаем просто и быстро

#3 SYB75

    Участник

  • Пользователи
  • PipPipPip
  • 87 сообщений
  • Пол:Мужчина
  • Город:Самара

Отправлено 31 Май 2018 - 15:45

Просмотр сообщенияKreator (31 Май 2018 - 15:36) писал:

Кажется, так было всегда. Не помню деталей, но по-моему, лампочки сбрасываются при изменении файла-ссылки. Но это не точно :) Я от этой практики сразу и ушёл.
Слои же Вы выключаете в файлах-ссылках?
Пробовали отключать слои не лампочкой, а солнцем (заморозить на всех ВЭ)?
Нет, так всегда не было. Так как если я подключаю модель генплана, я ж каждый раз не перенастраиваю слои и Заказчику передаю не с комментариями типа при открытии отключите заново слои такие то и такие то.

Пробовали "солнцем" - эффект тот же. Отсутствие эффекта. Я в приницпе вставил глючный файл в новый чертеж блоком с разбивкой и все ожило. Но причина такого поведения так и не ясна.

Сообщение отредактировал SYB75: 31 Май 2018 - 15:48


#4 yum

    Активист

  • Пользователи
  • PipPipPipPip
  • 640 сообщений
  • Пол:Женщина

Отправлено 31 Май 2018 - 17:04

В какой версии работаете.
Посмотрела в 10.0 на новых файлах - отключенные слои после переоткрытия остаются отключенными.
Если повторяется только на определенном файле, то пришлите его, пожалуйста, для анализа.

#5 SYB75

    Участник

  • Пользователи
  • PipPipPip
  • 87 сообщений
  • Пол:Мужчина
  • Город:Самара

Отправлено 01 Июнь 2018 - 09:49

Просмотр сообщенияyum (31 Май 2018 - 17:04) писал:

В какой версии работаете.
Посмотрела в 10.0 на новых файлах - отключенные слои после переоткрытия остаются отключенными.
Если повторяется только на определенном файле, то пришлите его, пожалуйста, для анализа.
Работаем в AutoCAD 2009 и NanoCAD СПДС 7.0
Сейчас комплект соберу, скину в личку.

#6 yum

    Активист

  • Пользователи
  • PipPipPipPip
  • 640 сообщений
  • Пол:Женщина

Отправлено 01 Июнь 2018 - 13:57

Спасибо. Файл, похоже прошел огонь, воду и медные трубы. Отдам на анализ специалистам, потому что причины такого поведения где-то глубоко. Пока вы нашли правильный вариант - копирование в новый файл.

#7 yum

    Активист

  • Пользователи
  • PipPipPipPip
  • 640 сообщений
  • Пол:Женщина

Отправлено 05 Июль 2018 - 18:04


Оказывается есть такая переменная - VISRETAIN.

0 - состояние слоев берется непосредственно из файла самой внешней ссылки
1 - состояние слоев берется из текущего файла

В приложенном файле установлено значение 0.

https://knowledge.au...6ED671-htm.html


#8 Kreator

    Активист

  • Пользователи
  • PipPipPipPip
  • 686 сообщений
  • Пол:Мужчина
  • Город:Краснодар

Отправлено 05 Июль 2018 - 19:35

Невероятно :)
Полховский А.В. Проектирование железнодорожных путей
nanoCAD Plus 10.1.4468.1506; MultiCAD.NET; Печатаем просто и быстро




Ответить



  


Количество пользователей, читающих эту тему: 1

0 пользователей, 1 гостей, 0 скрытых пользователей