Перейти к содержимому


ошибки в NanocadЭлектро


Сообщений в теме: 1059

#21 Электрик

    Продукт-менеджер

  • Продукт-менеджеры
  • PipPipPipPip
  • 3 543 сообщений
  • Пол:Мужчина

Отправлено 20 Апрель 2010 - 07:50

Просмотр сообщенияOgurcofff (20 Апрель 2010 - 06:04) писал:

Полная перезагрузка не помогла, очень жаль.
Здравствуйте!
Пришлите мне проект (electro@nanocad.ru) посмотрим в чем причина.

#22 gesper

    Активист

  • Пользователи
  • PipPipPipPip
  • 193 сообщений
  • Пол:Мужчина
  • Интересы:Электрика, ПО

Отправлено 20 Апрель 2010 - 08:19

Выслал, напишите потом тут или в письме, как оно.. заглючило или нет.

#23 Электрик

    Продукт-менеджер

  • Продукт-менеджеры
  • PipPipPipPip
  • 3 543 сообщений
  • Пол:Мужчина

Отправлено 20 Апрель 2010 - 13:40

Просмотр сообщенияgesper (20 Апрель 2010 - 08:19) писал:

Выслал, напишите потом тут или в письме, как оно.. заглючило или нет.
Ошибка воспроизвелась и у меня. Будем смотреть. Отпишусь обязательно.

#24 Ogurcofff

    Новичок

  • Пользователи
  • Pip
  • 5 сообщений

Отправлено 21 Апрель 2010 - 05:14

Я так расстроился что удалил проект. Попробую все заново начать. Потом отпишусь

#25 gesper

    Активист

  • Пользователи
  • PipPipPipPip
  • 193 сообщений
  • Пол:Мужчина
  • Интересы:Электрика, ПО

Отправлено 12 Май 2010 - 13:15

Дмитрий, в процессе исправления своих ошибок наткнулся на два глюка в NCE.

1) Приведен на скриншотах. Были созданы шкалы уставок и в процессе создания каталога аппаратов, когда выбирал очередную шкалу уставки, то случайно вместо того чтобы щелкнуть ее для выбора, отредактировал ее значение с 3 на 4. Мгновенно дерево шкал уставок частично поменяло свои значения с записей из БД, на 4, тоже и в списке БД по аппаратам защиты было. Лечилось закрытием\открытием окна вновь.
Прикрепленный файл  Шкала уставок1.JPG   88,4К   27 Количество загрузок:
Прикрепленный файл  Шкала уставок2.JPG   108,63К   26 Количество загрузок:

2) Тут нужна помощь, посмотрите это у меня или на всей сборке программы так.

Я присылал вам проект, там есть нужная БД. Заполняя БД с нужными нам аппаратами защиты накосячили и заполнили наскоро и неверно, сейчас исправляю, и вот "мусорную" запись шкалы убрать не могу из проекта. В присланом проекте у аппаратов серии БУМТ5130 параметры должны быть на основе Списка коммутационных характеристик, а шкалы уставок аппаратов вида "80..100" раньше были для этой серии, а теперь удалятся не хотят и говорят, что они привязаны к БУМТ5130.

#26 Электрик

    Продукт-менеджер

  • Продукт-менеджеры
  • PipPipPipPip
  • 3 543 сообщений
  • Пол:Мужчина

Отправлено 12 Май 2010 - 15:31

Просмотр сообщенияgesper (12 Май 2010 - 13:15) писал:

Дмитрий, в процессе исправления своих ошибок наткнулся на два глюка в NCE.

1) Приведен на скриншотах. Были созданы шкалы уставок и в процессе создания каталога аппаратов, когда выбирал очередную шкалу уставки, то случайно вместо того чтобы щелкнуть ее для выбора, отредактировал ее значение с 3 на 4. Мгновенно дерево шкал уставок частично поменяло свои значения с записей из БД, на 4, тоже и в списке БД по аппаратам защиты было. Лечилось закрытием\открытием окна вновь.
Прикрепленный файл Шкала уставок1.JPG
Прикрепленный файл Шкала уставок2.JPG

2) Тут нужна помощь, посмотрите это у меня или на всей сборке программы так.

Я присылал вам проект, там есть нужная БД. Заполняя БД с нужными нам аппаратами защиты накосячили и заполнили наскоро и неверно, сейчас исправляю, и вот "мусорную" запись шкалы убрать не могу из проекта. В присланом проекте у аппаратов серии БУМТ5130 параметры должны быть на основе Списка коммутационных характеристик, а шкалы уставок аппаратов вида "80..100" раньше были для этой серии, а теперь удалятся не хотят и говорят, что они привязаны к БУМТ5130.
Здравствуйте!
1) Попробую воспроизвести
2) Дело в том, что раньше параметр "Выбор коммутационных характеристик" имел значение "Раздельно" и была указана шкала уставок "80..100". Автомат это "помнит", поэтому программа не дает удалить эти шкалы. Так что пока оставьте "мусорные" шкалы в покое, а мы постараемся решить эту проблему.

#27 gesper

    Активист

  • Пользователи
  • PipPipPipPip
  • 193 сообщений
  • Пол:Мужчина
  • Интересы:Электрика, ПО

Отправлено 12 Май 2010 - 15:37

2) При поркладке кабелей повторно, это запоминание типа используемого кабеля было в "+", а тут "-".

#28 Электрик

    Продукт-менеджер

  • Продукт-менеджеры
  • PipPipPipPip
  • 3 543 сообщений
  • Пол:Мужчина

Отправлено 12 Май 2010 - 15:51

Просмотр сообщенияgesper (12 Май 2010 - 15:37) писал:

2) При поркладке кабелей повторно, это запоминание типа используемого кабеля было в "+", а тут "-".
Мы это "полечим"...

#29 gesper

    Активист

  • Пользователи
  • PipPipPipPip
  • 193 сообщений
  • Пол:Мужчина
  • Интересы:Электрика, ПО

Отправлено 14 Май 2010 - 14:02

Не помню, может уже всплывало, но программа не дает копировать МТЕКСТ. Переделываю шаблон групповой сети, и внутри блока не копируются почему то мтекст-ы.. с параметрами.

#30 gesper

    Активист

  • Пользователи
  • PipPipPipPip
  • 193 сообщений
  • Пол:Мужчина
  • Интересы:Электрика, ПО

Отправлено 03 Июнь 2010 - 16:06

Два кабеля диаметром 17,4 мм, программа с чистой душой запихивает в 30мм трубу.
По площади то влазит, а вот реально, по диаметру - нет.
И даже руками не задаш, что трубы не 1, а 2.

#31 Электрик

    Продукт-менеджер

  • Продукт-менеджеры
  • PipPipPipPip
  • 3 543 сообщений
  • Пол:Мужчина

Отправлено 04 Июнь 2010 - 07:46

Просмотр сообщенияgesper (03 Июнь 2010 - 16:06) писал:

Два кабеля диаметром 17,4 мм, программа с чистой душой запихивает в 30мм трубу.
По площади то влазит, а вот реально, по диаметру - нет.
И даже руками не задаш, что трубы не 1, а 2.
Это обязательно будет учтено в новой версии.

#32 gesper

    Активист

  • Пользователи
  • PipPipPipPip
  • 193 сообщений
  • Пол:Мужчина
  • Интересы:Электрика, ПО

Отправлено 09 Июнь 2010 - 13:29

1)
Прикрепленный файл  каб-контр.JPG   59,6К   25 Количество загрузок:
2)
Загнан штамп в блок, штамп по масштабу больше чертежа, но блок смаштабирован.
- Отредактировать Мтекст у которого 1 буква только в тексте - нереально.
- Почему то когда блок принимает изменения его, то текст в нем снова маштабируется куда то в сторону.

3) отрисовка схемы электрощита начинается с координат 5000:10000... Это не заметно при использовании шаблона чистого файла идущего по умолчанию, но если делаешь шаблонный файл с настройками под себя, то уже заметно, что не из 0 рисуется, а где то в стороне

#33 Электрик

    Продукт-менеджер

  • Продукт-менеджеры
  • PipPipPipPip
  • 3 543 сообщений
  • Пол:Мужчина

Отправлено 15 Июнь 2010 - 13:07

Просмотр сообщенияgesper (09 Июнь 2010 - 13:29) писал:

1)
Прикрепленный файл каб-контр.JPG
2)
Загнан штамп в блок, штамп по масштабу больше чертежа, но блок смаштабирован.
- Отредактировать Мтекст у которого 1 буква только в тексте - нереально.
- Почему то когда блок принимает изменения его, то текст в нем снова маштабируется куда то в сторону.

3) отрисовка схемы электрощита начинается с координат 5000:10000... Это не заметно при использовании шаблона чистого файла идущего по умолчанию, но если делаешь шаблонный файл с настройками под себя, то уже заметно, что не из 0 рисуется, а где то в стороне
1. Сфотографируйте, пожалуйста, еще и маску этой выноски в "Настройках выносок".
2. Пришлите файлик, а то что-то непонятно
3. Потерпите немного, решим эту задачу, когда будем реализовывать вставку рамки со штампом при генерации схемы сети. Это тоже, думаю, к концу года появится.

#34 gesper

    Активист

  • Пользователи
  • PipPipPipPip
  • 193 сообщений
  • Пол:Мужчина
  • Интересы:Электрика, ПО

Отправлено 15 Июнь 2010 - 13:21

Просмотр сообщенияЭлектрик (15 Июнь 2010 - 13:07) писал:

1. Сфотографируйте, пожалуйста, еще и маску этой выноски в "Настройках выносок".
2. Пришлите файлик, а то что-то непонятно
3. Потерпите немного, решим эту задачу, когда будем реализовывать вставку рамки со штампом при генерации схемы сети. Это тоже, думаю, к концу года появится.
1. на скриншоте в правом нижнем углу, выделена рамочкой
2. отправил

#35 Электрик

    Продукт-менеджер

  • Продукт-менеджеры
  • PipPipPipPip
  • 3 543 сообщений
  • Пол:Мужчина

Отправлено 15 Июнь 2010 - 13:49

Просмотр сообщенияgesper (15 Июнь 2010 - 13:21) писал:

1. на скриншоте в правом нижнем углу, выделена рамочкой
2. отправил
И то, и другое - ошибки. Будем править. Спасибо.

#36 oipop

    Посетитель

  • Пользователи
  • PipPip
  • 29 сообщений

Отправлено 08 Ноябрь 2010 - 16:32

Здравствуйте!
Скачал новую, 3.0, версию nanoCAD Электро. После запуска и загрузки всех библиотек, выдает окно с ошибкой "НЕУСТРАНИМАЯ ОШИБКА". Переустановка не помогла. Установил на компьютере коллеги, все нормально, загружается и работает. Вопрос: есть ли какой нибудь лог файл программы, и где он находиться, из которого можно узнать причину неустранимой ошибки? Спасибо.

#37 Вячеслав

    Участник

  • Пользователи
  • PipPipPip
  • 56 сообщений
  • Пол:Мужчина

Отправлено 08 Ноябрь 2010 - 18:54

Х...ня какая то с многострочным текстом

#38 bob2009

    Активист

  • Пользователи
  • PipPipPipPip
  • 274 сообщений
  • Пол:Мужчина

Отправлено 09 Ноябрь 2010 - 15:12

Добрый день!
Начал работу с 3 версией.
Попробовал создать УГО защищенного светильника с двумя заштрихованными (SOLID)секторами из четырех. В файле УГО все нормально выглядит: круг с двумя заштрихованными секторами и двумя незаштрихованными.
Вставляю новый созданный УГО защищенного светильника на план и он становится полностью заштрихованным, все 4 сектора заштрихованы, т.е. полностью весь круг заштрихован.
Ошибка?

#39 gesper

    Активист

  • Пользователи
  • PipPipPipPip
  • 193 сообщений
  • Пол:Мужчина
  • Интересы:Электрика, ПО

Отправлено 10 Ноябрь 2010 - 11:33

проверь масштабы на чертеже и режим штриховки...

#40 bob2009

    Активист

  • Пользователи
  • PipPipPipPip
  • 274 сообщений
  • Пол:Мужчина

Отправлено 10 Ноябрь 2010 - 13:50

Что я должен проверять?
Новый созданный блок УГО с заштрихованными (solid) областями (сектора круга) выглядит при открытии файла с УГО правильно, а при вставке на план заштрихованы не 2 сектора , а весь круг. Так что проверять?
Кстати, когда создавал новый УГО с штриховкой частей круга (секторов) штриховка при выборе точки работает странно. Не как в автокаде. Иногда заливает не выбранный сектор, а наоборот всю оставшуюся часть круга, а не сектор. Т.е. инверсно. Короче что то не так.





Количество пользователей, читающих эту тему: 1

0 пользователей, 1 гостей, 0 скрытых пользователей