Перейти к содержимому


Не получается создать псевдоним команды

Нанокад 10 nanocad 10 псевдоним

Сообщений в теме: 14

#1 Владимир42

    Активист

  • Пользователи
  • PipPipPipPip
  • 239 сообщений
  • Пол:Мужчина
  • Город:Кемерово

Отправлено 29 Май 2018 - 10:15

Добрый день!
Не могу создать свой псевдоним команды. Нет выбора команд в соответствующем окне «Выберите команду». Ввести имя команды в нужное поле тоже не помогает. На соседней машине тоже самое. Да еще и вылетает при закрытии открытых при этом окон «Выберите команду» или «Создать псевдоним».
Сталкивался ли кто-нибудь? Может что-то подскажите.

Прикрепленные файлы



#2 Hellen

    Активист

  • Пользователи
  • PipPipPipPip
  • 120 сообщений
  • Пол:Не скажу

Отправлено 29 Май 2018 - 10:27

Здравствуйте!
Очень странно у вас выглядит вкладка Псевдонимы, почему-то пуст столбец "Имя". Оно сразу так было? Или что перед этим меняли в cfg?
В правой части вкладки (список команд) у вас пусто, потому что выбран фильтр "Контролы".
Почему пуст список команд из диаложка "Выберите команду" - тоже неясно...
В общем, нужна подробная история изменений в кастомизаторе.

#3 Владимир42

    Активист

  • Пользователи
  • PipPipPipPip
  • 239 сообщений
  • Пол:Мужчина
  • Город:Кемерово

Отправлено 29 Май 2018 - 10:36

Просмотр сообщенияHellen (29 Май 2018 - 10:27) писал:

Здравствуйте!
Очень странно у вас выглядит вкладка Псевдонимы, почему-то пуст столбец "Имя". Оно сразу так было? Или что перед этим меняли в cfg?
В правой части вкладки (список команд) у вас пусто, потому что выбран фильтр "Контролы".
Почему пуст список команд из диаложка "Выберите команду" - тоже неясно...
В общем, нужна подробная история изменений в кастомизаторе.

В правой части вкладки хоть "Контролы", хоть "Команды", хоть "Все инструменты" - все одно пусто. Это просто в снимок экрана так попало, что там "Контролы". cfg вообще не трогал. Еще, если заменить уже существующий псевдоним, то программа при запуске сразу же крашится с неустранимой ошибкой. Само окно NC не появляется, даже приветственное не успевает - сразу окно об неустранимой ошибке. Помогла переустановка.
У меня сборка 4433, демо-версия.
Рядом у машина с версией 4426, лицензия. Тоже самое.

#4 Hellen

    Активист

  • Пользователи
  • PipPipPipPip
  • 120 сообщений
  • Пол:Не скажу

Отправлено 29 Май 2018 - 10:38

Настройки из 8.5 импортировали при первом запуске?
На вашей машине более ранние версии 10.0 стояли?

#5 Владимир42

    Активист

  • Пользователи
  • PipPipPipPip
  • 239 сообщений
  • Пол:Мужчина
  • Город:Кемерово

Отправлено 29 Май 2018 - 10:41

Нет, настройки из 8.5 не импортировал. Раньше стояла сборка 4426. Удалил ее перед установкой 4433.

#6 Hellen

    Активист

  • Пользователи
  • PipPipPipPip
  • 120 сообщений
  • Пол:Не скажу

Отправлено 29 Май 2018 - 10:47

Просмотр сообщенияВладимир42 (29 Май 2018 - 10:41) писал:

Нет, настройки из 8.5 не импортировал. Раньше стояла сборка 4426. Удалил ее перед установкой 4433.
После удаления очищали ProgramData, AppData, реестр?
Если нет: попробуйте для начала очистить реестр, папка 10.0 в разделе HKEY_CURRENT_USER\Software\Nanosoft\nanoCAD x64 Plus

А профиль не создавали новый? И что изменяли в Настройках (которые Options)?

#7 Владимир42

    Активист

  • Пользователи
  • PipPipPipPip
  • 239 сообщений
  • Пол:Мужчина
  • Город:Кемерово

Отправлено 29 Май 2018 - 10:52

Просмотр сообщенияHellen (29 Май 2018 - 10:47) писал:

Просмотр сообщенияВладимир42 (29 Май 2018 - 10:41) писал:

Нет, настройки из 8.5 не импортировал. Раньше стояла сборка 4426. Удалил ее перед установкой 4433.
После удаления очищали ProgramData, AppData, реестр?
Если нет: попробуйте для начала очистить реестр, папка 10.0 в разделе HKEY_CURRENT_USER\Software\Nanosoft\nanoCAD x64 Plus

А профиль не создавали новый? И что изменяли в Настройках (которые Options)?

ProgramData только вычистил, AppData и реестр не трогал.
Профиль новый создавал в настройках.
Но раньше все выше перечисленное как-то не влияло при установке не то что новых сборок, даже новых версий. Хватало удалить через панель управления и ProgramData почистить.

Попробую с чисткой реестра.

#8 Владимир42

    Активист

  • Пользователи
  • PipPipPipPip
  • 239 сообщений
  • Пол:Мужчина
  • Город:Кемерово

Отправлено 29 Май 2018 - 10:55

Чистка реестра помогла. Спасибо!

#9 Hellen

    Активист

  • Пользователи
  • PipPipPipPip
  • 120 сообщений
  • Пол:Не скажу

Отправлено 29 Май 2018 - 10:59

Просмотр сообщенияВладимир42 (29 Май 2018 - 10:55) писал:

Чистка реестра помогла. Спасибо!
Отлично!
Профиль как раз в реестре хранится. При установке новой сборки в пределах одной версии могут быть накладки, поэтому лучше очищать реестр перед установкой.

#10 Владимир42

    Активист

  • Пользователи
  • PipPipPipPip
  • 239 сообщений
  • Пол:Мужчина
  • Город:Кемерово

Отправлено 17 Октябрь 2018 - 11:41

Снова та же проблема. Теперь с NC Электро. Удалил старую версию, удалил папки Nanosaft из ProgramData и AppData, почистил реестр (HKEY_CURRENT_USER\Software\Nanosoft)
Чистка реестра после установки не помогла.

Прикрепленные файлы



#11 kolymba

    Активист

  • Пользователи
  • PipPipPipPip
  • 697 сообщений
  • Пол:Мужчина
  • Город:Владивосток

Отправлено 17 Октябрь 2018 - 12:53

Эту проблему в бета-тесте 10-ки Электро обсуждали... на такой сборке работали... так что придется ждать следующее обновление(

#12 Владимир42

    Активист

  • Пользователи
  • PipPipPipPip
  • 239 сообщений
  • Пол:Мужчина
  • Город:Кемерово

Отправлено 17 Октябрь 2018 - 16:35

Просмотр сообщенияkolymba (17 Октябрь 2018 - 12:53) писал:

Эту проблему в бета-тесте 10-ки Электро обсуждали... на такой сборке работали... так что придется ждать следующее обновление(

Как-то странно. Значит это было известно еще с бета-теста. Какого черта этот баг делает в официальном релизе?! Тем более, что это ж функционал базы, Электро тут никаким боком.
Хотелось бы услышать объяснение разработчика. И объявление когда выйдет следующая обновление. (Эмоции, однако!)

#13 dows

    Активист

  • Продукт-менеджеры
  • PipPipPipPip
  • 2 957 сообщений
  • Пол:Мужчина
  • Город:Москва
  • Интересы:САПР

Отправлено 18 Октябрь 2018 - 12:18

тонкость в том, что в платформе это исправили в сентябре (не просто было исправить, поэтому раньше не получилось). Но Электро собралось на чуть более свежей сборке и к ним это исправление не попало. В отличнии, например, от СПДС/Механика, которые сейчас это исправление содержат. По идее при следующей пересборке Электро должно это исправление включить...

В официальной nanoCAD Plus 10 исправление появится с недели на неделю - сейчас занимаемся тестированием 10.1, которая ожидается до конца месяца...

Коллеги, я понимаю ваши эмоции. Но процесс разработки - это распределенный процесс: одни разработчики делают одно, другие другое. Каждая группа разработчиков концентрируются на наиболее критичную для них задачу. А выпуск продукта - это сборка разных функций в одно целое, стабилизация и тестирование. Обычный цикл "сборка-тестирование-пересборка" - это от 2 до 4 недель. В какой-то момент продукт-менеджеры должны принять решение: выпустить то, что есть, или дальше пересобирать-тестировать (т.е. еще на месяц откладываем выпуск). Сейчас ПМ по Электро принял решение выпускать для того, чтобы дать новую версию продукта пользователям. Выдал, а сам взялся за следующий цикл обновления-тестирования.
С уважением,
Денис Ожигин

Сайты: www.archicad.ru, www.nanocad.ru

#14 Владимир42

    Активист

  • Пользователи
  • PipPipPipPip
  • 239 сообщений
  • Пол:Мужчина
  • Город:Кемерово

Отправлено 18 Октябрь 2018 - 12:31

Может нас минула чаша сия, но в NC Plus 10 с проблемой с файлами конфигурации в нашей конторе столкнулся только 1 пользователь и то выше Hellen написал как это лечить. Т.е. создается впечатление, что это был какой-то единичный, неповторяющийся сбой.
Вы же мне сейчас говорите, что исправление этого бага еще даже не дошло до релиза NC Plus 10. Что-то не понимаю ничего.
В любом случае подскажите когда будет обновление NC Электро? А то работать без привычных быстрых клавиш, псевдонимов и прочего очень не удобно. Даже ленту под себя не переделать! Работа замедляется!

P.S. ИМХО. Баг достаточно "сильный", как по мне, то выпускать продукт с таким нельзя

#15 dows

    Активист

  • Продукт-менеджеры
  • PipPipPipPip
  • 2 957 сообщений
  • Пол:Мужчина
  • Город:Москва
  • Интересы:САПР

Отправлено 18 Октябрь 2018 - 12:55

там проблема гораздо более глубокая и обостряется именно с вертикальными приложениями, которые загружают свой ленточный интерфейс (новый функционал, не все мы продумали, когда делали новый тип интерфейса) - поэтому вы на форуме нашли вершину айсберга.
если спрашивать мое мнение - да, баг в Электро достаточно сильный. И я пытался убедить уважаемого Электрика на тему обновления. Но Дима меня выслушал и принял свое решение, на мой взгляд достаточно взвешенное - дать новый функционал Электро пользователям как на базе nanoCAD, так и на базе Revit, а не задержаться еще на месяц... Это все некий уровень ответственности и принятие решения, которое не всем может понравиться.
С уважением,
Денис Ожигин

Сайты: www.archicad.ru, www.nanocad.ru





Количество пользователей, читающих эту тему: 1

0 пользователей, 1 гостей, 0 скрытых пользователей