Перейти к содержимому


Kreator

Регистрация: 18 сент. 2014
Offline Активность: Сегодня, 18:35
-----

Мои темы

Пропадают форматы для PDFCreator

14 Июнь 2018 - 14:59

Коллеги, всех приветствую!
Относительно недавно я чувствовал себя практически джедаем печати из NC. Но тут в очередной раз что-то сломалось, и мой волшебный люминесцентный меч потух :(
В общем, ситуация такая:
Когда-то давно (ещё на NC6) я наделал своих форматов в NC через настройки - от А4 до А2x7. Их я использовал для наборов параметров печати, которые создал для каждого формата в шаблоне.
Изначально пользуюсь PDFCreator - он мне больше всего понравился совокупностью удобства, наличия минимально необходимого функционала и универсальностью (идёт как системный виртуальный принтер), к тому же бесплатен. Соответственно, все наборы параметров печати привязаны к нему. С выходом новых версий NC я импортировал настройки из старой версии либо использовал экспортированный файлик реестра, который затирал форматы в ветке NC и добавлял мои форматы. И всё было хорошо.
Сейчас почему-то на одной машине наблюдаю такое поведение: принтер PDFCreator перестал видеть добавленные мной форматы - их просто нет в списке. Привести к этому могли какие-то ошибки/ошибочные действия с интерфейсом (я добавлял меню и панельку, настраивал положение, после этого интерфейс иногда сбрасывался), хотя где тут связь. Форматы в настройках на месте, другие принтеры их видят. PDFCreator переустанавливал. Уже не знаю, куда лезть. Очень не хочется всё удалять и заново ставить, надо бы понять, что и откуда берётся.
Кто в курсе нутра, подскажите, откуда принтер (вообще любой и PDFCreator в частности) берёт список форматов? Как с принтерами взаимодействует NC в части передачи ему списка своих форматов (тех, которые в принтере отсутствуют, но в настройки добавлены - без значка принтера)? Ну и традиционно - кто виноват и что делать?
Пример файла реестра для NC 8.1+ x64 по ссылке. Настраиваю NC 8.1+ x32 (расширение пока не сделал для 8.5 и 10).

Оповещения

07 Апрель 2018 - 13:02

Добрый день!
Заметил, что не работает оповещение о новых темах в форумах, находящихся на отслеживании. Вроде раньше работало. По-моему, даже в период беты 2018 получал оповещения о новых темах в соответствующей ветке. А сейчас тишина по всем фронтам.

proxy собственных custom объектов не отображаются

04 Апрель 2018 - 19:25

Добрый день!
В процессе бета-тестирования решил ради интереса пооткрывать планы для просмотра. Работать в них в 10ке не могу, потому что в планах написанные мной кастомы. Но речь не о 10ке, а вообще о любой версии, в которой не загружена DLL.
Итак, есть файл с кастомом. Открываю, вместо прокси-графики - прямоугольник. Открываю в 8.1 (где DLL есть) - всё нормально, кастом работает.
Создаю пустой файл, вставляю кастом, открываю в другой вресии без DLL - всё прекрасно, графика есть.
Открываю в 8.1 файл, который не показывает графику, удаляю всё, очищаю-проверяю, вставляю новый кастом, сохраняю. Открываю открываю в другой вресии без DLL - всё равно прямоугольник.
Попробовал другие планы пооткрывать - всё хорошо, прокси-графика на месте. Видимо, проблема в данном конкретном файле.
Прошу всемогущих гуру посмотреть, в чём тут дело, и можно ли исправить.

Не отображаются блоки в видовом экране

22 Март 2018 - 14:44

Приветствую вас, воины клавиатуры и мыши!
Получил я на днях от наших братьев-геодезистов очередную итерацию топографии, заменил старую на новую, вставил её в план внешней ссылкой. И тут заметил, что крестики координатной сетки не отображаются в видовых экранах (ни в старых, ни в новых). Естественно, проверил файл. Оказалось, что топография разбросана по уровням (не в одной плоскости). Подумал, что в этом всё дело. Сделал проверки, очистку, уплощение всех объектов. Переоткрыл - всё равно не видно. Дальше только опытные сенсеи могут разобрать, что не так с этим файлом.
P.S. Обряды освящения проводить не стал - ПК не водозащищённый.

Краш при подгрузке частичного файла конфигурации интерфейса

07 Март 2018 - 10:14

Добрый день!
Столкнулся с такой неприятностью - стала вылетать программа при вызове контекстного меню во время выполнения команды. Например, черчу полилинию, жму ПКМ - привет. Если чертить отрезок, то просто отменяется команда. В настройках ПКМ во время выполнения - показать контекстное меню, если у команды есть опция.
Произошло это после добавления панельки и меню через загрузку частичного файла cfg. Если этот файл прописать в #include и открыть основной файл конфигурации (например, nCadPlusC.cfg). Тогда всё работает. Может, частичный файл должен как-то оформляться отдельно?