Jump to content

Некоторые блоки не видны


Recommended Posts

Добрый день!

 

Открываю в нано 21 файлы созданные в нано20, а блоки (не все) в чертеже не отображаются в пространстве модели. В листе на видовом экране их видно.

При печати и при предпросмотре они видны. Куда копать?

Link to comment
Share on other sites

2 часа назад, Bucho сказал:

Блок не отображается.

Когда выводишь на печать, то блоки видно.

какой именно? скриншотик, плиз...

Link to comment
Share on other sites

3 часа назад, Lion007 сказал:

какой именно?

 

Возможно, имеется ввиду это:

 

Спойлер

image.thumb.png.98c46745ca8facd0dd3c14988d33f1af.png

 

 

При выборе этой области справа налево (секрамка) появляется еще и динамический блок

Спойлер

image.png.800ebb20a2370dbebae72199189b6807.png

 

При незначительном изменении перспективы появляется еще и изображение этого блока

Спойлер

image.thumb.png.03841e9cdbc01544ec523a41b4f9c269.png

 

 

При попытке печати этой области на просмотре этот блок виден

Спойлер

image.png.f4586863d6b8baf3935819c69d13b9b7.png

 

 

Ну и просто при копипасте этого блока в новый файл он вполне себе виден

 

Спойлер

image.png.ac101a0926f06f446745f4940ed6fe14.png

 

 

 

PS. Кстати, если удалить два огромных блока с подосновой (не спрашивайте, почему их 2 и в виде букашек к ним оформленные чертежи прицеплены) и регенерировать чертеж, то этот блок тоже становится виден

Edited by EdwardSt
  • Thanks 1
Link to comment
Share on other sites

Вот вы правильно все приметили. Многие блоки не видны, а они есть ;)

 

Да в новом файле все путем, но как быть со старыми ?

Вот пришла нужда внести правку в старый проект, а многих блоков не вижу, и первая мысль - капец, все с нуля делать

Link to comment
Share on other sites

Если  блоки с подосновой уменьшить в 1000 раз (это то, что я попробовал через изменение масштаба), то тот динамический блок опять же становится виден.

Предполагаю, что остальные тоже элементы станут видны.

 

Я бы предложил удалить блоки с подосновой, если они не нужны.

Они нигде не участвуют на оформленных листах.

Да и такая мешанина коней и людей -  вообще не очень...

 

Ну а из академического интереса неплохо бы выяснить, почему такие эффекты с видимостью

Link to comment
Share on other sites

есть смутное ощущение, что это пространственный индекс дурит... координаты большие, торчащие сбоку блоки подосновы - еще больше, вот он и путается, бедолага... а печать без него работает, поэтому ей пофигу!
но, конечно, баррдак, будем чинить!

  • Like 4
  • Thanks 1
Link to comment
Share on other sites

  • 4 weeks later...
19 часов назад, Bucho сказал:

Есть лекарство?

Кроме описанных выше не нашёл.

В 18.05.2021 в 15:23, EdwardSt сказал:

 

Я бы предложил удалить блоки с подосновой, если они не нужны.

Отмечу также, что при работе с эти файлом в автокаде  2021 происходит вылет после редактирования этого блока.

Link to comment
Share on other sites

  • 4 months later...

Здравствуйте! Подобная ерунда у меня тоже произошла. Только в модели блоки были видны, а на листе и при печати пропали. Перед этим файл переходил из автокада в nanocad 21. Все слои включены и разморожены. После получаса камланий с бубном, открыл в nanocad 20 и на листе (при включённом режиме модель) обнаружил новые слои: был слой ПС – появился слой ПС @ 1 (2), был слой 0 – появился слой 0 @ 1. Они-то и были заморожены, а в nanocad 21 и в автокаде не отображались в диспетчере слоёв, проявились только nanocad 20. После разморозки и блоки появились и эти слои стали отображаться во всех программах. Все ранее пропавшие блоки оказались в этих новых слоях.

Link to comment
Share on other sites

  • 3 months later...

В рамках открытого проекта не отображалась часть блоков, в том числе и пропадали только что созданные.

 

Единственный костыль который возвращал их оказалось изменение положения блока относительно оси Z на любую величину отличную от 0. 

 

Уважаемые разработчики обратите пожалуйста свой взор на данную проблему.

Link to comment
Share on other sites

11 минут назад, Ushunder сказал:

взор на данную проблему

Файл с проблемой похоже отцепился(((

  • Like 1
Link to comment
Share on other sites

  • 2 months later...

на самом деле, эту бяку уже починили, причем довольно давно. вот правдв не помню, когда именно, поэтому точно не скажу, в новогоднее обновление попало, или нет. но в текущих девелоперских версиях все фурычит :)
так что в ближайшем обновлении точно должно быть.

  • Like 1
Link to comment
Share on other sites

  • 7 months later...

Поймал эту бяку с экс-автокадовским файлом, марка оси не видны в листе и на печати. Это та же проблема?

версия 22.0.6013.3747 сборка 6122

 

оси проблема.dwg

Edited by CSpace
  • Like 2
Link to comment
Share on other sites

4 минуты назад, Kreator сказал:

блоки не разбиваются

В редакторе разрешить расчленение..

  • Like 1
Link to comment
Share on other sites

1 минуту назад, doctorraz сказал:

В редакторе разрешить расчленение..

Спойлер

1622784852_.thumb.png.217b55c928e23bd0a44aaee5ab0ef36e.png

Но спасибо, забыл про это чудо.

  • Haha 1
Link to comment
Share on other sites

15 минут назад, Kreator сказал:

Что-то пошло не так

обычная история если собрать в блок коня и трепетную лань мультикад объекты и примитивы dwg, изменить масштаб блока

и расчленить...

мультикад объекты масштабируются иначе чем примитивы чертежа

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Tell a friend

    Love Официальный форум компании Нанософт? Tell a friend!
×
×
  • Create New...