Перейти к содержанию

Рекомендуемые сообщения

Первое что хотелось бы отметить - непонятная работа алиасов (сокращений команд). Если это не баг - разъясните пожалуйста, как с ними нужно работать? А то нажимаю e(англ.) хочу стереть понимаешь - а мне предлагают окружность нарисовать :angry:

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Первое что хотелось бы отметить - непонятная работа алиасов (сокращений команд). Если это не баг - разъясните пожалуйста, как с ними нужно работать? А то нажимаю e(англ.) хочу стереть понимаешь - а мне предлагают окружность нарисовать :angry:

 

Добрый день!

 

Возможно, Вы нажимали с, алиас для Окружности?

 

Алиасы и Шорткаты задаются в файле NSpds.pgp

 

Например, для окружности

 

Круг=sCircle

C=sCircle

Круг2=sCircleByDiamemter

Круг3=sCircleBy3Points

 

Для удаления выбранного объекта ( команда Удалить) - можно нажать клавишу Del

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Гость Станислав

В процессе работы обнаружилось:

1. Вчера нарисовал план сооружения, проставил размеры, сохранил, закрыл. Сегодня пришел, открыл... часть размеров в исходном масштабе, часть изменила первоначальный вид. Меняешь как надо, сохраняешь, закрываешь и открываешь снова - снова та же неприятность. :angry:

2. Команда копировать свойства работает в ограниченном диапазоне действий (масштаб размеров не меняет например).

3. При работе с файлом более 1 Мб начинается притормаживание. Чем больше файл, тем больше тормозит. Файл размером 8 Мб не открыл вообще.

4. Привязка и отслеживание работают корректно только при приближении к месту пересечения (например) в плотную. Если объект (отрезок) далеко, то привязаться к середине или к краю корректно не получается. Что это, настройки не правильные, или программа не отлажена? :blink:

5. Работать с видовыми экранами не удобно, т.к. нет возможности "с листа" редактировать объекты в модели.

6. В модели не отображаются толщины линий. Не удобно, когда работаешь одновременно с большими и мелкими узлами/объектами.

7. Сложно работать с командой "подобие". (ну мне по крайней мере неудобно).

8. Нет команды "облако".

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

2 Станислав

 

По 1-му и 3-му - в каком формате сохраняется документ, dwg или cws?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Гость Станислав
2 Станислав

 

По 1-му и 3-му - в каком формате сохраняется документ, dwg или cws?

 

В dwg.

На данный момент, перед распечаткой, удобнее мелочи дорабатывать на acad2005+spds т.к. он ПОКА производительнее (болш2005 и не нужно, я полагаю т.к. принципиальных отличий нет).

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Добрый день!

 

Возможно, Вы нажимали с, алиас для Окружности?

 

Алиасы и Шорткаты задаются в файле NSpds.pgp

 

Например, для окружности

 

Круг=sCircle

C=sCircle

Круг2=sCircleByDiamemter

Круг3=sCircleBy3Points

 

Для удаления выбранного объекта ( команда Удалить) - можно нажать клавишу Del

 

В том-то и дело, что нажимая на букву У(англ-E) я получаю в ком строке вообще C(англ.) и в итоге рисую круг!!! Как такое может быть? Так же и с другими алиасами - творится черти-что. Особенно в русской раскладке. Например пишу "линия" получаю ";8ния" Разве это не баг? :blink:

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Гость Станислав

Обнаружил ошибку: при вставке группы объектов (не взорванных) из dwg акад файла в dwg нано файл - вылетает без сохранения. Все открыто наником. :angry:

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
В том-то и дело, что нажимая на букву У(англ-E) я получаю в ком строке вообще C(англ.) и в итоге рисую круг!!! Как такое может быть? Так же и с другими алиасами - творится черти-что. Особенно в русской раскладке. Например пишу "линия" получаю ";8ния" Разве это не баг? :blink:

 

Не обнаружил таких ошибок. Сборка какая?

 

Обнаружил ошибку: при вставке группы объектов (не взорванных) из dwg акад файла в dwg нано файл - вылетает без сохранения.

Через клипборд или как?

post-5-1218192584.png

post-5-1218192600.png

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Не обнаружил таких ошибок. Сборка какая?

 

NanoCAD SPDS

Версия 1.0.1037.615

Возможно punto switcher пакостит?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
NanoCAD SPDS

Версия 1.0.1037.615

Возможно punto switcher пакостит?

Этот легко может, отключите для nanoCAD в Пунто, для эксперимента.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Надо устранить: при создании стандартной детали мастер скриптов убивает функции, которые создал пользователь (мастер их вообще не генерирует, например "OnDialogChanged"). Пускай предупреждает, что мол есть неизменённые функции, но убивать-то их зачем?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Мастер скриптов - это утилита для визуальной генерации скриптов, предназначенная для начинающих пользователей.

Если Вы достаточно хорошо разбираетесь в языке скриптов, для того, чтобы править их вручную (в чем у меня сомнения уже нет), то лучше вообще не запускать мастер скриптов.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Абсолютно согласен с тем, что "лучше вообще не запускать мастер скриптов", но согласитель, ведь можно вручную и ошибок навалять.

Кстати об ОШИБКАХ: при создании стандартной детали, если в мастере скриптов задать условия отображения какого либо параметра имеющего пояснение отличное от имени переменной, то он (мастер) вставляет в скрипт функцию с именем переменной, а скрытие/отображение элементов происходит по указанию её описания. Во как!!!

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для мастера скриптов не задавалась цель создания полнофункциональной среды разработки, ведь нужно только описать поведение объекта на чертеже. В любом случае, конструктивные пожелания по улучшению интерфейса приветствуются с благодарностью.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Скрытие \ отображение действует только на пользовательские (не табличные) параметры, флажки и переключатели.

Если действительно нужна интерактивность диалога, лучше пользоваться формами.

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

При экспорте таблиц в MS Excel теряется содержимое отдельных ячеек (заменяются на {\rtf1\ansi\ansicpg1251\deff0\ итд). Проблема не зависит от содержимого ячейки. Также в некоторых пустых ячейках появляется символ Я.

 

О притормаживании: наблюдаются задержки при выполнении простых операций(выделение, перенос объекта) при одновременной работе с AutoCAD. При этом в автокаде эти же операции выполняются без задержек.

(замечено при 512М ОЗУ/120М или менее свободно)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

всем доброго времени суток!

Присматриваемся к вашему продукту....начал сейчас тестировать НанокадСПДС 2.0

и первая ошибка с которой столкнулся это при построении таблиц

Например создаю ведомость отделки помещений, при первом запуске, при выборе загрузить из базы, отображаются все базы, при повторной попытке создать таблицу, захожу....и....от базы остается только 2 строки и все!

Перезагружаю прогу, опять такая же фигня :(

Пробовал на разных совершенно компах.....проблема везде одинаковая

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Доброго времени суток!

Глюк при работе с закладками.

Переходим на любую закладку (Лист1, Лист2, ..., А0). Рисуем линии, дуги и прочее нормально. Нажимает ЛЮБУЮ кнопку изменения режима (Шаг, Сетка и пр.) ДВА раза (т.е. изменяем состояние и возвращаем состояние обратно). Рисуем линию, дугу, круг и прочее - получаем просто ОГРОМНУЮ толщину линии. В закладке модели при этом всё рисуется нормально

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Доброго времени суток!

Глюк при работе с закладками.

Переходим на любую закладку (Лист1, Лист2, ..., А0). Рисуем линии, дуги и прочее нормально. Нажимает ЛЮБУЮ кнопку изменения режима (Шаг, Сетка и пр.) ДВА раза (т.е. изменяем состояние и возвращаем состояние обратно). Рисуем линию, дугу, круг и прочее - получаем просто ОГРОМНУЮ толщину линии. В закладке модели при этом всё рисуется нормально

 

Ловил то же самое при перетаскивании основной надписи в пространстве листа, получается огромная толщина линии.

Еще замеченное:

1. При зумировании колесом мыши, периодически перестает приближать/удалять (залипает) то тех пор пока не перепозиционируешь с помощью нажатия на колесо и перетаскивания.

2. При изменении цвета фона с черного на белый до перезагрузки документа не инвертируются цвета линий, т.е. они становятся невидимыми.

 

Вопрос к администрации. Сейчас раздумываем над покупкой абонимента, в случае его покупки будет доступна версия с исправленным глюком при зумировании?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

1.При проставлении размера радиуса текст некорректно располагается над полкой выноски.

Можно понаблюдать за его смещением относительно полки при вращениии/выборе места для стрелки текста.

Если в настройках указать - параллельно размерной линии - все хорошо.

2.ПЛОХО работает выбор точки штриховки - не показывает границы, как и при выборе границ на удаление островка

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Здравствуйте, всем! большое спасибо за присланные замечания. я зафиксировал ошибки толщин линий в пространстве листа и положения текста на размере. по инверсии фона ошибка уже известна. по поводу зуммирования: попробуйте переключиться в настройках. Средства-Параметры - Системные настройки - Настройки аппаратного ускорения графики. Необходимо выбрать один из трех вариантов поочередно. После установки каждого варианта перезапустите программу. Попробуйте операции зуммирования и панорамирования на пустом и готовом чертежах. в будущей версии мы постараемся закрыть подавляющее большинство найденных ошибок, поэтому владельцы абонементов получат устойчивую версию бесплатно.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

А у меня такой вопрос: на фирме ставил NanoCAD 2.0 на 6 машин. Из них на 4х пошел нормально, а на 2х тормозит просто жутко. Курсор еле движется. Причем на этих 2х машинах автокад + спдс работает отлично. Пробовал менять настройки аппаратного ускорения, при первом и третьем варианте тормозит, а вот если выбрать второй вариан "аппаратного ускорения", то рисует без линий, т.е. видно только начальную и конечную точки. Может кто сталкивался, подскажите. Параметры машины: Windows 7 32bit, 1024 ОЗУ, AMD Athlon 2Ghz, видео 256Мб. P.S. Просьба комменты о том, что во всем Windows 7 не писать, т.к. у меня самого стоит "семерка" и проблем с "тормозами" нет.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

:D Тесты проводилсь на

Двух одинаковых машинах core2 2.6 hd3400 2 гб озу

Программа работала по разному

1. на одном тормозила безбожно установка размеров передвижка в близи.

2. на другом вроде бы прелично но при большом количестве объектов непрятно тормозило при меремещении по экрану и зумированию.

1 - решилось закачкой свежих драйверов видео на оф сайте но проблема зумирования осталась как и на втором ПК.

2 - свойства раб.стола -> параметры -> дополнительно -> диагностика -> аппаратное ускорение на одно деление назад.

Лаги от большого количества объектов прошли на обоих компах.

Сейчас данная сапр стоит на 20 все счастливо работают.

диагностика аппаратное ускорение на одно деление назад - вроде такая же проблема решалась также в 2004 АВТОГАДЕ :)

Надеюсь это кому нить поможет :)

Проверено на всех модулях Nanocad!

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Доброго дня

При открывании файлов каждый раз летят шрифты. Приходится каждый из текстов редактировать, указывать нужный шрифт. Сохраняем. Открываем - опять все слетело.

Указываем нужный шрифт в настройке стиля. Ничего не переписывается, и отображается криво.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

А, и еще. СПДС не открывает файлы. Что интересно, даже те, с которыми работала вчера, и которые вчера же сохраняла. Спасибо еще база есть. Поэтому открываем в базе, сохраняем в базе. После этого открываем в СПДС. Работаем. Но до первого закрытия. Дальше все сначала. Это чем-нибудь лечится?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Присоединяйтесь к обсуждению

Вы можете написать сейчас и зарегистрироваться позже. Если у вас есть аккаунт, авторизуйтесь, чтобы опубликовать от имени своего аккаунта.

Гость
Ответить в этой теме...

×   Вставлено с форматированием.   Восстановить форматирование

  Разрешено использовать не более 75 эмодзи.

×   Ваша ссылка была автоматически встроена.   Отображать как обычную ссылку

×   Ваш предыдущий контент был восстановлен.   Очистить редактор

×   Вы не можете вставлять изображения напрямую. Загружайте или вставляйте изображения по ссылке.

Загрузка...

×
×
  • Создать...