Jump to content

ошибки в NanocadЭлектро


Recommended Posts

  • 5 weeks later...

Обнаружена ошибка (или фича, возможно).

Если пост управления подключить к щиту с помощью мастера контрольных соединений, а потом этот же пост подключить к другому щиту, то в ЭТМ, этот пост будет отображаться в обоих щитах...

 

Это нехорошо, на мой взгляд.

Edited by Lion2032
Link to comment
Share on other sites

5 часов назад, Lion2032 сказал:

или фича, возможно

это вероятнее всего

5 часов назад, Lion2032 сказал:

этот же пост подключить к другому щиту

не удаляя ранее созданного контрольного соединения, то абсолютно логично что

5 часов назад, Lion2032 сказал:

этот пост будет отображаться в обоих щитах

и кабели так-же будут посчитаны для обоих соединений, и в кабельном журнале учтены

Не вижу тут никакой ошибки, контрольных соединений может быть много, и не обязательно только что от одного щита.

Link to comment
Share on other sites

12 часов назад, Walkmax сказал:

это вероятнее всего

не удаляя ранее созданного контрольного соединения, то абсолютно логично что

и кабели так-же будут посчитаны для обоих соединений, и в кабельном журнале учтены

Не вижу тут никакой ошибки, контрольных соединений может быть много, и не обязательно только что от одного щита.

 

Так-то да, но все таки есть определенная недоработка.

Нужна как-то понятная пользователю нумерация, что ли, типа ЩС1-ПК1, ЩС1-ПК2.

А то подключат блин, две фазы под один зажим блин, и свалят все на проектировщиков )))

 

Хотя, конечно, это продукт не для автоматчиков, можно и так оставить...

Хотя лучше "допилить" наверное...

Edited by Lion2032
  • Like 1
Link to comment
Share on other sites

Обнаружился интересный момент, ПО не отслеживает соответствие высоты лотка диаметру кабеля, т.е. для кабеля диаметром ~60 мм лоток 50x200 проходит проверку на заполнение. Проблема в том, что крышка не закроет лоток. Эта особенность чем-то обусловлена, или спишем её в БАГи?

  • Like 2
Link to comment
Share on other sites

17 часов назад, Walkmax сказал:

Обнаружился интересный момент, ПО не отслеживает соответствие высоты лотка диаметру кабеля, т.е. для кабеля диаметром ~60 мм лоток 50x200 проходит проверку на заполнение. Проблема в том, что крышка не закроет лоток. Эта особенность чем-то обусловлена, или спишем её в БАГи?

Баг. Раньше работало... Будем править.

Link to comment
Share on other sites

Строю криволинейные трассы. При просмотре в 3D они отображаются обычными линиями, КНС не показывается.

Спойлер

image.png.72b73fb5efb24679e99273ec3a243710.png

 

Пробую экспортировать в 3D - криволинейная трасса строится прямым отрезком :(

Спойлер

image.png.ccd308f0184db63190cbdc35824ac60f.png

 

Спойлер

image.png.519f947728033d3965707b51df27a3f7.png

 

 

 

UPD: В проекте, в котором было несколько криволинейных участков при экспорте в 3D DWG или IFC вылетал баг-репорт. Заменил все участки прямыми трассами - баг-репорт пропал, всё норм экспортируется.

Edited by Ingvarr_
Link to comment
Share on other sites

5 часов назад, Ingvarr_ сказал:

Строю криволинейные трассы ......

Ну это как бы не новость.

Хотя вот кое что уже сделано. Но очень не стабильно, то геометрия трассы произвольно меняется, то вообще исчезает, надо быть осторожным с этими кривыми.

Спойлер

ESVfhcdb57.gif.2f35eed10d0dbd94e1d796fd53773e22.gif

 

Edited by Walkmax
Link to comment
Share on other sites

Заметил интересный момент

Если в межэтажных переходах (трасса разбегается и вверх и вниз)

проложены трассы только наверх, то выноска "трассы приходящие снизу"

показывает трассы уходящие наверх.

Link to comment
Share on other sites

  • 2 weeks later...

Здравствуйте, коллеги!

После перехода на НЭ20 скала возникать ошибка при попытке экспортирования в базу данных проекта из другой базы. После чего работать продолжать можно, но изменения уже в базе не сохраняются.

скрин ошибки прилагаю. ошибка повторяется на разных компах при разработке проекта с нуля в том числе

скан ошибки.png

добавлено через 2 минуты

дополню, что при создании проекта с нуля эта ошибка вылезает не сразу, а спустя неск. часов

Link to comment
Share on other sites

2 минуты назад, аааа сказал:

После перехода на НЭ20 скала возникать ошибка

Добрый, очень странно... Ни разу такого не было, возможно что-то с размещением баз данных или может с диском что?

Link to comment
Share on other sites

3 минуты назад, Andrey_ka сказал:

Добрый, очень странно... Ни разу такого не было, возможно что-то с размещением баз данных или может с диском что?

Да не похоже, разные люди на разных машинах это делали. сейчас попробую свою базу выложить в обменник

Link to comment
Share on other sites

46 минут назад, аааа сказал:

Да не похоже, разные люди на разных машинах это делали

абсолютно нормально выполняется экспорт/импорт...

  • Thanks 1
Link to comment
Share on other sites

  • 2 weeks later...

Добрый день!

А что в 20 версии электро выноска сечения не работает?

Устанавливаю на трасу

CW_SET_TRACE_CUT - Выноска сечения

А в ответ тишина....

смотрю мастер сечений - нет ничего...

nanoCAD x64 Plus 20.1.5304.5304

nanoCAD Электро 20.0.522.5220

пишу в коммандной строке

sect

нет комманды

А как работать?

Или что-то не так поставил? Подскажите

 

Edited by rus_m
Link to comment
Share on other sites

44 минуты назад, rus_m сказал:

А что в 20 версии электро выноска сечения не работает?

Добрый, работает и команда CW_SET_TRACE_CUT, и из контекстного меню... Проверьте другие команды...

Link to comment
Share on other sites

1 час назад, rus_m сказал:

Добрый день!

А что в 20 версии электро выноска сечения не работает?

Устанавливаю на трасу

CW_SET_TRACE_CUT - Выноска сечения

А в ответ тишина....

смотрю мастер сечений - нет ничего...

nanoCAD x64 Plus 20.1.5304.5304

nanoCAD Электро 20.0.522.5220

пишу в коммандной строке

sect

нет комманды

А как работать?

Или что-то не так поставил? Подскажите

 

Скорее всего в этой трассе либо совсем нет КНС, либо там труба или кабель-канал.

Программа делает сечения только для лотковых трасс.

Link to comment
Share on other sites

Только в одном проекте, который начинался в 11 версии.

КНС лотка в трассе есть не ставится выноска сечения.mkv

есть кабели, а выноски не хочет ставить. (

 

Если проект начинаю в 20 версии, все нормально, выноски сечения работают.

Edited by rus_m
Link to comment
Share on other sites

1 час назад, rus_m сказал:

Только в одном проекте, который начинался в 11 версии.

попробуйте перепроложить трассы используя команду "проложить в существующих..." возможно что-то с базой данных и программа не видит там лоток...

Link to comment
Share on other sites

Попробовал не помогает. Это проблема только одного конкретного проекта.

Проверил на других даже начатых в 11 версии - работает

Edited by rus_m
Link to comment
Share on other sites

33 минуты назад, rus_m сказал:

Это проблема только одного конкретного проекта.

Сложно что-то сказать без самого проекта, удалите лишнюю информацию и выложите, может кто-то и докопается до причины...

Link to comment
Share on other sites

В 01.03.2021 в 15:35, rus_m сказал:

Добрый день!

А что в 20 версии электро выноска сечения не работает?

Устанавливаю на трасу

CW_SET_TRACE_CUT - Выноска сечения

А в ответ тишина....

смотрю мастер сечений - нет ничего...

nanoCAD x64 Plus 20.1.5304.5304

nanoCAD Электро 20.0.522.5220

пишу в коммандной строке

sect

нет комманды

А как работать?

Или что-то не так поставил? Подскажите

 

 

Попробуйте удалить проблемную трассу, и заново проложить, что ли...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Tell a friend

    Love Официальный форум компании Нанософт? Tell a friend!
×
×
  • Create New...