Jump to content

ошибки в NanocadЭлектро


Recommended Posts

В 06.04.2020 в 10:55, Lion2032 сказал:

Это баг или фича?

2020-04-06_10-53-08.png.4acac219d6c9a29f0884ed307946f61d.png2020-04-06_10-50-07.png.04fde67af2066384b7f7b67b3572ae13.png

Почему не отображаются несколько подключенных электроприемников?

 

Давайте разбираться. Опишите ситуацию подробнее. Какие ЭП пропали?

Link to comment
Share on other sites

 

10 минут назад, Электрик сказал:

Давайте разбираться. Опишите ситуацию подробнее. Какие ЭП пропали?

 

Если на группе (гр.9) "висит" один потребитель (ШПО-3.1), то всё отображается нормально: в выноски видно потребителя

Если на группе(гр.10) висит два и более потребителя (ШПО-7.1, ШПО-8.1), то в выноске отображается прочерк.

(Если в группе оставить только один потребитель, то всё отображается нормально)

 

P.S. Скан выноски выложу чуть позже.

Edited by Lion2032
Link to comment
Share on other sites

В 13.04.2020 в 15:11, polomnik сказал:

Почему подключённый трансформатор (УГО ящик с трансформатором) ведёт себя неадекватно в отчётах? Проверил в 8-й и 11-й версиях

Излагаю:

-Подключён к автомату один трансформатор с указанием мощности

1.Однолинейка строится с этим трансом без аномалий по выводу данных (длина кабеля, мощность, падение, ток –всё на месте)

2.В электротехническом расчёте нет ничего по этой группе, стоит резерв

3.В таблице групповых щитков (из проводника) выводится кабель, мощность, Рток и ток КЗ, но стоит резерв, а в таблицу групповых щитков (из электротехнической модели) не выводится нечего (стоит резерв)

4.В расчёте нагрузок трансформатор участвует, но всегда с cosФ=1 игнорируя данные из ГХ, хотя название из ГХ подхватывает.

5.Ну а то, что кабели за таким трансформатором не выводятся в кабельных журнал –это бородатая тема.

2. Задайте ГХ. Расчет будет вестись в соответствии с заданными в ГХ данными.

Спойлер

image.thumb.png.665ac98adaff8431c58210e55161be59.png

3. Выводите из Менеджера проекта. "Резерв" нужно править.

4. Будем править.

5. Это да... Постараюсь продавить эту задачу к 20-ке.

добавлено через 1 минуту
3 часа назад, Lion2032 сказал:

 

 

Если на группе (гр.9) "висит" один потребитель (ШПО-3.1), то всё отображается нормально: в выноски видно потребителя

Если на группе(гр.10) висит два и более потребителя (ШПО-7.1, ШПО-8.1), то в выноске отображается прочерк.

(Если в группе оставить только один потребитель, то всё отображается нормально)

 

P.S. Скан выноски выложу чуть позже.

Судя по выноске, там выводится не потребитель, а маркировка кабеля. Нужно как-то похитрее настроить выноску.

  • Like 1
Link to comment
Share on other sites

20 часов назад, Электрик сказал:

2. Задайте ГХ. Расчет будет вестись в соответствии с заданными в ГХ данными.

ОК, по всем пунктам понял, Спасибо, будем подождать. Не понял по п.2. В ГХ только Cos и Кс, Способа задания нагрузки для трансформатора (как для иных потребителей) не предусмотрено. Мощность только по данным из базы.

Выходные данные приходят в норму, только если подключить за трансформатором нагрузку и туже нагрузку подключить к питающей группе (т.е. трансформатор как разветвитель). И лично меня всё бы устроило, если бы кабель за трансформатором (как за разветвителем) попадал в кабельный журнал. Даже проблемка с выгрузкой линий за трансформатором в отчёт ТКЗ, (которым там нечего делать т.к. во всех моих случаях это слаботочная линия) –меркнет на фоне пустоты в кабельном журнале. И только поэтому приходится сначала подключать все линии за трансформатором, что бы просчитать падения на 24-48В (подобрать кабель) и потом сносить все подключения и создавать их заново через контрольное подключение, что даёт учёт кабеля в журнале и отсутствие этих (слаботочных) линий в отчётах ТКЗ. И тут вылез косяк, что один транс на группе -неадекватен в отчётах. Пару лет я этого не замечал, а до того пару лет не замечал пробелов в журнале, после чего пришлось использовать «контрольные» пере-подключения.   Хорошо, что в общей мощности эти трансформаторы всегда учитывались.

Предполагаю, что ящик с трансформатором изначально не получил должного внимания, т.к. его типовое назначение –для ремонтного освещения со всеми вытекающими послаблениями по учёту нагрузки, НО  на данный момент этот (подобный) инструмент очень нужен для построения слаботочного освещения. Уже не припомню случаев, когда фасадное, архитектурное освещение делалось бы на 230В. Было бы очень круто не только поправить проблемку с журналом, но и наделить трансформатор параметром «пусковой ток» и возможностью исключения подключений за трансформатором из расчётов ТКЗ.

-Ещё, до кучи, вспомнил один проблем -отсутствие параметров таблицы для слаботочных кабелей, чтобы настроить их вывод в спецификацию. Пока приходится маскировать их под контрольные, где нет возможности корректно показать многопарный кабель. Хотя эта тема потянет за собой обновление фильтра для кабельного журнала с учётом слаботочных кабелей. Ну ведь это возможно?

p.s. Слаботочные кабели нужны для интерфейсных линий управления, например: KNX

  • Like 1
Link to comment
Share on other sites

Цитата

ОК, по всем пунктам понял, Спасибо, будем подождать. Не понял по п.2. В ГХ только Cos и Кс, Способа задания нагрузки для трансформатора (как для иных потребителей) не предусмотрено. Мощность только по данным из базы.

 

1.png

Link to comment
Share on other sites

  • 4 weeks later...

Да как так?

Кладу гладкую трубу с поворотом, устанавливаю количество труб -10, запускаю подбор соединительных элементов (поворот подобрался), иду в спецификацию, и там труба в норме, а поворот –один. Что я делаю не так?

Тоже самое и с Т-отводом.

Делаю в 11.0, проверяю в 8.5, проверяю в ОПС 8,5 –везде такая картина.  

Link to comment
Share on other sites

8 часов назад, polomnik сказал:

Да как так?

Кладу гладкую трубу с поворотом, устанавливаю количество труб -10, запускаю подбор соединительных элементов (поворот подобрался), иду в спецификацию, и там труба в норме, а поворот –один. Что я делаю не так?

Тоже самое и с Т-отводом.

Делаю в 11.0, проверяю в 8.5, проверяю в ОПС 8,5 –везде такая картина.  

 

Это матрица, бро...

Link to comment
Share on other sites

В 15.05.2020 в 23:08, polomnik сказал:

Да как так?

Кладу гладкую трубу с поворотом, устанавливаю количество труб -10, запускаю подбор соединительных элементов (поворот подобрался), иду в спецификацию, и там труба в норме, а поворот –один. Что я делаю не так?

Тоже самое и с Т-отводом.

Делаю в 11.0, проверяю в 8.5, проверяю в ОПС 8,5 –везде такая картина.  

Похоже, это баг. Будем срочно править.

Link to comment
Share on other sites

  • 2 weeks later...

Странная ошибка, не могу включить 3D вид в одном файле проекта! У кого возникала такая ошибка и как ее избегать?

https://yadi.sk/d/xtNSFVUpoTUf5Q

И еще бывает такое, прокладываю трассу и потом не могу изменить ее, приходится переключаться в 3D вид и удалять ее и снова прокладывать

P.S.: 1. Методом исключения выяснил что это трассы, а какая из неизвестно

        2. Открыл на другом компьютере, сборка ПО такая же, все работает как по маслу

 

Edited by AntSam
Link to comment
Share on other sites

 

Спойлер

image.png.88c09aa60f8ff3908b8e12dcc17833f8.png

 

добавлено через 3 минут

Посмотрите мастером проверок. Может какая-то трасса "сломалась" или не на ноле лежит. У меня как то было, что трасса сломалась. Причём, насколько помню, нашел её потом практически случайно - кабели не прокладывались в этом месте.

Еще, если переключиться в ленту, появилась какая-то волшебная кнопка "Проверка целостности данных проекта". Не знаю, что делает. В классическом виде её почему-то нет и поэтому нашел её случайно. Но вдруг поможет.

 

  • Like 2
Link to comment
Share on other sites

  • 2 weeks later...

Здравствуйте.

Не знаю вопрос этой темы или нет. Если нет, то направьте куда следует, пж.

Не запускается редактор базы данных редактор базы данных из PS CS v. 19.0.4969.4969

В комменте к ошибке выдает следующее:

<<Cad платформа: 
Продукт: 
Версия продукта:  x86
Версия ОС: Microsoft Windows NT 6.1.7601 Service Pack 1 x86

=========================================
Exception: System.NullReferenceException: Ссылка на объект не указывает на экземпляр объекта.
   в Cadwise.Studio.Utils.ApplicationInformationBase.get_ShortVersion()
   в Cadwise.Platform.ModuleBase.CwModulePlatform.CreateMutex()
   в Cadwise.Platform.ModuleBase.CwModulePlatform.RunSystem()
   в Cadwise.SelfLoader.ContainerInitializer.Initialize()
   в ElectricaDataBaseEditor.Program.Start()
   в ElectricaDataBaseEditor.Program.Main()
===================================Stack trace================================
   в System.Environment.GetStackTrace(Exception e, Boolean needFileInfo)
   в System.Environment.get_StackTrace()
   в Cadwise.Studio.Utils.ExceptionLogger.GetInfo(Exception exception, String description)
   в Cadwise.Studio.Utils.ExceptionLogger.Log(Exception exception, String description)
   в Cadwise.Studio.Utils.ExceptionLogger.Log(Exception exception)
   в ElectricaDataBaseEditor.Program.Main()

>>

Подскажите, пж, как вылечить проблему?

Link to comment
Share on other sites

Здравствуйте!

Напишите мне в личку ваш телефон. Завтра попробуем разобраться.

добавлено через 5 минут
В 04.06.2020 в 09:38, AntSam сказал:

Странная ошибка, не могу включить 3D вид в одном файле проекта! У кого возникала такая ошибка и как ее избегать?

https://yadi.sk/d/xtNSFVUpoTUf5Q

И еще бывает такое, прокладываю трассу и потом не могу изменить ее, приходится переключаться в 3D вид и удалять ее и снова прокладывать

P.S.: 1. Методом исключения выяснил что это трассы, а какая из неизвестно

        2. Открыл на другом компьютере, сборка ПО такая же, все работает как по маслу

 

Больше не воспроизводилось?

Link to comment
Share on other sites

Вопрос разработчикам или знатокам. Интересует параметр «Активное сопротивление полюса R, мОм», точнее его серьёзное влияние на значение нагрева кабеля (при КЗ), подключённого через плавкие вставки. Можно только гадать -на сколько адекватно данный параметр заполнен в базах, но у разных производителей плавких вставок этот параметр гуляет от 0 до 100 и сильно разниться для схожих по характеристикам предохранителей. В моём случае, линия защищаемая автоматом, где данный параметр имеет значение 0,2мОм,  демонстрирует нагрев 29С, а при её подключении через плавкие вставки, где тот же параметр имеет значение 0,5мОм –выдаёт нагрев 441С. Опытным путём выяснилось, что перегрев через плавкие вставки убирается только при значительном увеличении данного значения, –например: 50мОм снижает нагрев уже до 153С. Но увеличение данного значения у автомата (до тех же 50мОм) практически не повлияло на нагрев кабеля. Ещё на расчёт нагрева (с плавкими вставками) повлиял коэф. увеличения активного сопротивления кабеля (в настройках свойства проекта значится как: Снагр. кз), где значение 2 (1 по умолчанию) дал приемлемое значение нагрева кабеля, но это больше смахивает на подгонку результатов, тем более, что тупо упали и ударный ток и ТКЗ, порождая все вытекающие проблемы для длинных линий. Остаётся главный вопрос, -стоит ли мне беспокоиться о нагреве кабеля при подключении через плавкие вставки и увеличивать сечение кабеля или это баг расчёта на предохранителях?

  • Like 1
Link to comment
Share on other sites

8 часов назад, polomnik сказал:

стоит ли мне беспокоиться о нагреве кабеля при подключении через плавкие вставки?

Вообще не стоит т.к.:

  1. во-первых, в сетях до 1 кВ кабели не подлежат проверке (п.1.4.2, ПУЭ)
  2. во-вторых даже если есть такое желание, то проводники защищённые плавкими вставками не проверяются (п.1.4.3, ПУЭ)
  • Like 2
Link to comment
Share on other sites

8 часов назад, polomnik сказал:

Вопрос разработчикам или знатокам

 

4 минуты назад, Walkmax сказал:
  • во-первых, в сетях до 1 кВ кабели не подлежат проверке (п.1.4.2, ПУЭ)
  • во-вторых даже если есть такое желание, то проводники защищённые плавкими вставками не проверяются (п.1.4.3, ПУЭ)

От себя добавлю, что нагрев кабеля, в основном, зависит от времени отключения аппарата защиты. Хотите "подогнать" делайте в базе данных из автомата предохранитель и устанавливайте время отключения нужное вам...

  • Like 2
Link to comment
Share on other sites

2 часа назад, Andrey_ka сказал:

 

От себя добавлю, что нагрев кабеля, в основном, зависит от времени отключения аппарата защиты. Хотите "подогнать" делайте в базе данных из автомата предохранитель и устанавливайте время отключения нужное вам...

Спасибо за участие. Я не хочу ничего подгонять. Меня напрягает полученный результат. Почему он такой на вставках? Это баг или достоверный результат учитывающий, предположим -медленную отработку плавкой вставки, и тогда его не стоит игнорить прикрываясь ПУЭ, или как?

Link to comment
Share on other sites

29 минут назад, polomnik сказал:

Спасибо за участие. Я не хочу ничего подгонять

А не нужно подгонять, просто в программе нет возможности задать время отключения вставки плавкой (это уже где-то на просторах форума обсуждалось)... А от этого времени напрямую зависит нагрев при КЗ. Один из участников форума, честно скажу, не помню кто, выкладывал файл с времятоковыми характеристиками и расчетом... Поэтому можно "обмануть" программу подсунув ей вместо предохранителя автомат с нужным временем отключения и получить искомый результат.

Edited by Andrey_ka
  • Like 2
Link to comment
Share on other sites

1 час назад, polomnik сказал:

Спасибо за участие. Я не хочу ничего подгонять. Меня напрягает полученный результат. Почему он такой на вставках? Это баг или достоверный результат учитывающий, предположим -медленную отработку плавкой вставки, и тогда его не стоит игнорить прикрываясь ПУЭ, или как?

Не стоит обращать внимание на результаты этого расчета. Andrey_ka все написал правильно. В программе в БД на предохранители нет данных по времени отключения, поэтому результаты расчета получаются недостоверные.

Как обойти эту ситуацию Андрей, также все правильно написал.

  • Like 1
Link to comment
Share on other sites

15 часов назад, Электрик сказал:

Не стоит обращать внимание на результаты этого расчета. Andrey_ka все написал правильно. В программе в БД на предохранители нет данных по времени отключения, поэтому результаты расчета получаются недостоверные.

Как обойти эту ситуацию Андрей, также все правильно написал.

ОК. Спасибо Всем, понял, принял. 

Link to comment
Share on other sites

В 17.06.2020 в 00:20, Электрик сказал:

Здравствуйте!

Напишите мне в личку ваш телефон. Завтра попробуем разобраться.

добавлено через 5 минут

Больше не воспроизводилось?

 Причина была в трассе, возникает при следующих ситуациях:

1. Электроприемник стоит близко к границе помещения

2. Привязка находится в середине уго

3. Трасса прокладывается сначала вдоль границы потом под прямым углом идет к уго (на картинке показано)

4. После прокладки трассу иногда не возможно выделить

Спойлер

2020-06-18_15-27-06.png

 

 

Edited by AntSam
Link to comment
Share on other sites

5 минут назад, AntSam сказал:

3. Трасса прокладывается сначала вдоль границы потом под прямы углом идет к уго (на картинке показано)

 

Это две разные("вдоль границы" и "идет к уго") трассы, которая не выделяется?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Tell a friend

    Love Официальный форум компании Нанософт? Tell a friend!
×
×
  • Create New...