Перейти к содержанию
Николай Sim

Настройка интерфейса в nanoCAD Plus 8.0

Рекомендуемые сообщения

Здравствуйте.

 

Перешел с 7 на 8 nanocad и вот с чем столкнулся в первые дни использования.

  • Периодически сбрасывается настроенный интерфейс. Все панели за исключением созданных мной отображаются "по умолчанию". Не могу пока поймать причину по которой это происходит. Может у кого еще так?
  • По тому же интерфейсу: не понятно, почему убрали возможность перетаскивать кнопки с одних панелек на другие в реальном режиме. По-моему это была одна из самых удачных "фишек" 7-ки. Теперь же все приходится настраивать в меню настройках интерфейса, да еще и перезапускать программу чтобы изменения вступили в силу. Может я чего не нашел?
  • Почему-то не видно курсора ввода текста в Мтексте. То есть, он есть, но, как будто сливается с фоном. Менял цветовые темы оформления - не помогает.
  • При переносе объектов с выносками, полки выносок отзеркаливаются в первоначальное положение, в котором они были созданы.
  • Пришлось повозится с клавиатурными привязками команд. Хотя при первом запуске nano предложил импортировать настройки из предыдущей версии, я так и не понял, что он перенес. PGP файл в разделе пользовательских команд оказался пуст. Но это еще пол беды. Скопировав данный раздел из предыдущей версии, не получил желаемого результата. Пришлось опять таки править все через меню настройки интерфейса.

Странно, что все эти проблемы вылезли в файлах, которые создавались в 7-ке. Я бы понял, если бы это вылезло в ex-Автокадовских чертежах, но тут чистый Nano. Всего этого в предыдущей версии не было.

 

PS Система win 7 x 64

 

PPS Спасибо за долгожданные подшивки, но почему не допилили возможность перетаскивания листов курсором. Чтобы настроить порядок листов в подшивке порой по нескольку раз приходится применять команды вверх-вниз.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Здравствуйте.

Перешел с 7 на 8 nanocad и вот с чем столкнулся в первые дни использования.

 

Здравствуйте, Николай!

Попробуем разобраться с вашими проблемами.

1. Что вы подразумеваете под сбрасыванием интерфейса? Панели меняют своё положение/видимость? Или вы перемещаете кнопки с панели на панель? Или что-то другое сбрасывается?

2. А как вы их перетаскивали в семёрке? Перетаскивание через Alt работает, но мы не рекомендуем так делать.

3. По поводу курсора в МТексте. Проблема была обнаружена только на двух компьютерах пользователей (ваш второй). Пока непонятно, что происходит. Поэтому вопросы:

- Пробовали переключать OpenGL/DirectX?

- Не пробовали обновить драйвера видеокарты?

- Вы делали миграцию настроек из предыдущей версии при первом запуске?

4. С выносками было бы неплохо выявить последовательность действий, с первого раза воспроизвести не удалось.

5. Переносятся настройки из диалога Настройки.

 

Проблемы 3 и 4 повторяются тольно на файлах из нанокад7? А если то же сделать в 8, повторяются?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Здравствуйте. Перешел с 7 на 8 nanocad и вот с чем столкнулся в первые дни использования.
Здравствуйте, Николай! Попробуем разобраться с вашими проблемами.

 

Здравствуйте, Hellen.

  1. Под "сбрасыванием интерфейса" я подразумеваю изменение положения панелей инструментов и их наличие/отсутствие. К примеру, я убрал ненужные панели, нужные перетащил на свои места (они у меня плавающие), отключил отображение ненужных кнопок в нижней строке (сетка, и шаг), спрятал командную строку. При следующем запуске, все отображается, по умолчанию, как будто я ничего не настраивал. Кажется я поймал причину: это происходит, когда что-то делалось в настройках и потребовался перезапуск. Если не лазит в настройки, то интерфейс сохраняется.
  2. С Alt-ом действительно работает. Это же очень удобно! Почему Вы не рекомендуете так делать? В семерке просто при включении настроек интерфейса активизировалась эта функция перетаскивания.
  3. По поводу курсора в МТексте - в режиме DirectX действительно все отображается. Другое дело, что производительность в DirectX не позволяет мне работать. Видимо дело в драйверах или самой видеокарте. У меня на ноуте ATI HD 4570 довольно древнее железо, но раньше все работало.
  4. С выносками прикол: создайте обычную позиционную, поверните полку выноски вертикально вниз, передвинте или скопируйте выноску.... У меня так только с позиционными и только с полкой вертикально вниз.
  5. По настройкам - понятно.

Проблема №3 по всей видимости, только в файлах, созданных в 7-ке. Сейчас, после изменения параметров графической подсистемы в пространстве модели курсор есть, а в листе он снова с фоном сливается. При создании нового файла в 8-ки и там, и там курсор имеется.

 

Проблема №4 - чисто в 8-ке появилась, не зависимо от версии создания файла.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Здравствуйте. Перешел с 7 на 8 nanocad и вот с чем столкнулся в первые дни использования.
Здравствуйте, Николай! Попробуем разобраться с вашими проблемами.

 

Здравствуйте, Hellen.

  1. Под "сбрасыванием интерфейса" я подразумеваю изменение положения панелей инструментов и их наличие/отсутствие. К примеру, я убрал ненужные панели, нужные перетащил на свои места (они у меня плавающие), отключил отображение ненужных кнопок в нижней строке (сетка, и шаг), спрятал командную строку. При следующем запуске, все отображается, по умолчанию, как будто я ничего не настраивал. Кажется я поймал причину: это происходит, когда что-то делалось в настройках и потребовался перезапуск. Если не лазит в настройки, то интерфейс сохраняется.
  2. С Alt-ом действительно работает. Это же очень удобно! Почему Вы не рекомендуете так делать? В семерке просто при включении настроек интерфейса активизировалась эта функция перетаскивания.
  3. По поводу курсора в МТексте - в режиме DirectX действительно все отображается. Другое дело, что производительность в DirectX не позволяет мне работать. Видимо дело в драйверах или самой видеокарте. У меня на ноуте ATI HD 4570 довольно древнее железо, но раньше все работало.
  4. С выносками прикол: создайте обычную позиционную, поверните полку выноски вертикально вниз, передвинте или скопируйте выноску.... У меня так только с позиционными и только с полкой вертикально вниз.
  5. По настройкам - понятно.

Проблема №3 по всей видимости, только в файлах, созданных в 7-ке. Сейчас, после изменения параметров графической подсистемы в пространстве модели курсор есть, а в листе он снова с фоном сливается. При создании нового файла в 8-ки и там, и там курсор имеется.

 

Проблема №4 - чисто в 8-ке появилась, не зависимо от версии создания файла.

 

1. Спасибо, теперь понятно. Сброс происходит, если вы в Интерфейсе перенастроили что-то для

- команд из правого списка,

- в закладке Главное меню,

- в закладке Панели инструментов.

В остальном сброс не должен происходить.

2. Дело в том, что эти "онлайн-изменения" не записываются в конфигурационный файл, а значит, вы удивитесь, когда зайдете в настройки пользовательского интерфейса, а панельки будут выглядеть без изменений.

3. Спасибо, будем разбираться.

4. Спасибо за подробное описание, зарегистрировали ошибку в базе.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

То же постоянно происходит сброс интерфейса на "по умолчанию". Как то можно это предотвратить? Устал настраивать....

Версия - nanoCAD ЖБ 4.0.3636.2317 сборка 268

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Присоединяйтесь к обсуждению

Вы можете написать сейчас и зарегистрироваться позже. Если у вас есть аккаунт, авторизуйтесь, чтобы опубликовать от имени своего аккаунта.

Гость
Ответить в этой теме...

×   Вставлено с форматированием.   Восстановить форматирование

  Разрешено использовать не более 75 эмодзи.

×   Ваша ссылка была автоматически встроена.   Отображать как обычную ссылку

×   Ваш предыдущий контент был восстановлен.   Очистить редактор

×   Вы не можете вставлять изображения напрямую. Загружайте или вставляйте изображения по ссылке.

Загрузка...

×
×
  • Создать...