Перейти к содержанию

Рекомендуемые сообщения

Здравствуйте. У меня такая проблема. Иногда встречалась в NanoCAD 8.1 Plus и часто в NanoCAD 11 Plus (в котором сейчас работаю), в старых версиях такого не было. Создаю лист, в лист вставляю рамку (рамка своя сделана блоком), в рамке есть различный текст и вставляю таблицу nanocad (см. рис.1), так несколько листов. Далее все редактирую, сохраняю и при следующем открытие данного файла  на некоторых листах возникает такая проблема: ничего нельзя выделить элементы все видно, но они не выделяются, соответственно и не редактируются, видовые экраны я не ставлял в лист. Если нажать два раза на среднюю клавишу мышки , то будет центрируется не только рамка с таблицей, но и пустая область, а если еще и нажать регенерация, то появится красный прямоугольник, который тоже нельзя выделить (я его точно не создавал) (см. рис.2). Если начать приближать-удалять, то красный прямоугольник сразу становится не видимым. Если долго щелкать на таблице, то она открывается и при этом опять появляется красный прямоугольник, но рамку и текст в нем редактировать никак нельзя. Таблица была сделана в NanoCAD 8.1. Что это за проблема? При том она не на всех листах проявляется. Заранее спасибо.

Рис.1.jpg

Рис.2.jpg

Ссылка на сообщение
Поделиться на другие сайты

Хорошо бы файл посмотреть. Есть смутное ощущение, что правили что-то подобное, но сходу не могу найти.

Ссылка на сообщение
Поделиться на другие сайты
2 часа назад, yum сказал:

Хорошо бы файл посмотреть. Есть смутное ощущение, что правили что-то подобное, но сходу не могу найти.

 

Проблема на листах РМГ4р и РМГ5р.dwg

Ссылка на сообщение
Поделиться на другие сайты

В вашем файле все селектируется. В 11.0 редактирую, сохраняю, открываю - селектируется. Тут нужно понять - как повторить.

Ссылка на сообщение
Поделиться на другие сайты

В 11.0 была проблема с таблицами, которые редактировались в 11.0 и затем открывались в 10.1 - они частично пропадали до редактирования их в 10.1. Может это связано?

Ссылка на сообщение
Поделиться на другие сайты
8 часов назад, NewNarKotik сказал:

проблема: ничего нельзя выделить элементы все видно, но они не выделяются, соответственно и не редактируются,


nanoCAD 11.1
 

Спойлер

image.png.726d8438998c53dcf30d95db2c368122.png


Выбор объектов, зуммирование, происходит нормально

Спойлер

image.png.95fe59790003de0908836dc853da3c54.png

 

Команды "Регенерация" и "Показать все" отрабатываются нормально.

 

Таблица на редактирование также открывается нормально.

Спойлер

image.png.86036caaa49b05ab813c9984f2f19566.png

 

Спойлер

image.png.10e189aaa20d779b67e7c00c938641c9.png

 

Видимо, какие то дополнительные условия.

 

- Может быть надо переустановить программу, предварительно почистив хвосты.

- Может быть параллельно стоят или запущены какие то другие приложения.

- Попробовать сменить режим видеодрайвера в nanoCAD.

- Попробовать поиграть с темами Windows (хотя это и маловероятно).

С выложенным файлом проблема осталась ?
Там явно вычищены какие то графические элементы типа факсимиле и логотипа.

Ссылка на сообщение
Поделиться на другие сайты
4 часа назад, yum сказал:

В вашем файле все селектируется. В 11.0 редактирую, сохраняю, открываю - селектируется. Тут нужно понять - как повторить.

 

1 час назад, A.Kudrjashov сказал:


nanoCAD 11.1
 

  Версия (Показать контент)

image.png.726d8438998c53dcf30d95db2c368122.png


Выбор объектов, зуммирование, происходит нормально

  Выбор объектов (Показать контент)

image.png.95fe59790003de0908836dc853da3c54.png

 

Команды "Регенерация" и "Показать все" отрабатываются нормально.

 

Таблица на редактирование также открывается нормально.

  Редактор таблиц (Показать контент)

image.png.86036caaa49b05ab813c9984f2f19566.png

 

  Редактирование определения блока (Показать контент)

image.png.10e189aaa20d779b67e7c00c938641c9.png

 

Видимо, какие то дополнительные условия.

 

- Может быть надо переустановить программу, предварительно почистив хвосты.

- Может быть параллельно стоят или запущены какие то другие приложения.

- Попробовать сменить режим видеодрайвера в nanoCAD.

- Попробовать поиграть с темами Windows (хотя это и маловероятно).

С выложенным файлом проблема осталась ?
Там явно вычищены какие то графические элементы типа факсимиле и логотипа.

Дома пришел, в версии 8.1 тоже открывает нормально тот файл который залил, но в исходном файле через 8.1 была такая же проблема. Вообще этот косяк начался , когда поставили 11 версию, когда стал открывать файлы сделанные версией 8.1. И еще когда создал файл в 11 версии, а потом пришел домой и поработал в 8.1.

  То что в файле все подтерто, на работе стирал из рамки все редактирование блоков из другого листа, так как рамка блоком. Но файл, который залил такие же проблемы проявлял и после удаления всех листов и редактирования рамки-блока.

  В какой момент происходит порча листа сам пока не понимаю. В пн. попробую залить исходный не редактированный файл. На работе стоят Нанокад 5 (бесплатная-пробная), НаноКад 8.1 Плюс, Геоника 8.5 и Нанокад 11 Плюс. Может попробую открыть разными версиями. 

 

 

2 часа назад, Kreator сказал:

В 11.0 была проблема с таблицами, которые редактировались в 11.0 и затем открывались в 10.1 - они частично пропадали до редактирования их в 10.1. Может это связано?

))) А это тоже отдельная проблема, только у меня когда открываю в 8.1. Но слава Богу они пропадут не полностью а видно заголовки таблиц, щелкая на заголовок ее можно открыть и если что-то в ней поменять, то она становится видимой 

Ссылка на сообщение
Поделиться на другие сайты
В 17.01.2020 в 15:10, yum сказал:

В вашем файле все селектируется. В 11.0 редактирую, сохраняю, открываю - селектируется. Тут нужно понять - как повторить.

 

В 17.01.2020 в 17:51, A.Kudrjashov сказал:


nanoCAD 11.1
 

  Версия (Показать контент)

image.png.726d8438998c53dcf30d95db2c368122.png


Выбор объектов, зуммирование, происходит нормально

  Выбор объектов (Показать контент)

image.png.95fe59790003de0908836dc853da3c54.png

 

Команды "Регенерация" и "Показать все" отрабатываются нормально.

 

Таблица на редактирование также открывается нормально.

  Редактор таблиц (Показать контент)

image.png.86036caaa49b05ab813c9984f2f19566.png

 

  Редактирование определения блока (Показать контент)

image.png.10e189aaa20d779b67e7c00c938641c9.png

 

Видимо, какие то дополнительные условия.

 

- Может быть надо переустановить программу, предварительно почистив хвосты.

- Может быть параллельно стоят или запущены какие то другие приложения.

- Попробовать сменить режим видеодрайвера в nanoCAD.

- Попробовать поиграть с темами Windows (хотя это и маловероятно).

С выложенным файлом проблема осталась ?
Там явно вычищены какие то графические элементы типа факсимиле и логотипа.

Вот файл с глюками. Еще заметил, что если открываешь редактор блоков, редактируешь там все, а потом выходишь с сохранением, пока сохраняет вылезает таблица работ моих, с листа на котором глюк. Может быть проблема в том что ставили 11 плюс не удаляя 8.1 плюс. Также в модели появилась таблица моих работ, хотя я ее туда не вставлял. 

Проблема на листах РМГ4р и РМГ5р .dwg

Ссылка на сообщение
Поделиться на другие сайты
1 час назад, NewNarKotik сказал:

Вот файл с глюками.


Загрузил в nanoCAD 11. На листах "РМГ1" и "РМГ4р" были видны красные глючные прямоугольники, при наведении на которых мыши, высвечивалось, что это видовые экраны.

Спойлер

image.png.69967c5233db4759c5956f966daf4225.png

 

Спойлер

image.png.29dec1aff20831d131c1fc5f5f64e005.png

 

После применения "Утилиты - Проверка документа", ошибки были исправлены и глюки исчезли.

Исправленный файл и логи прикладываю.

 

Проверка документа.txtПроблема на листах РМГ4р и РМГ5р _2.dwg

 

 

 

Ссылка на сообщение
Поделиться на другие сайты
1 минуту назад, A.Kudrjashov сказал:


Загрузил в nanoCAD 11. На листах "РМГ1" и "РМГ4р" были видны красные глючные прямоугольники, при наведении на которых мыши, высвечивалось, что это видовые экраны.

  РМГ1 (1) (Показать контент)

image.png.69967c5233db4759c5956f966daf4225.png

 

  РМГ4р (1) (Показать контент)

image.png.29dec1aff20831d131c1fc5f5f64e005.png

 

После применения "Утилиты - Проверка документа", ошибки были исправлены и глюки исчезли.

Исправленный файл и логи прикладываю.

 

Проверка документа.txt 18 \u043a\u0411 · 0 загрузок Проблема на листах РМГ4р и РМГ5р _2.dwg 3 \u041c\u0411 · 1 загрузка

 

 

 

Спасибо!! Есть ли какие-нибудь предположения с чем могут быть связаны данные глюки, что бы избежать дальнейших. Или какие-то рекомендации. Так и не смог отследить после чего конкретно возникает проблема. 

Ссылка на сообщение
Поделиться на другие сайты
24 минуты назад, NewNarKotik сказал:

Есть ли какие-нибудь предположения с чем могут быть связаны данные глюки

 

У меня предположений нет. Надо, чтобы разработчики посмотрели исходный глючный файл и логи исправлений.
Может быть, поймут в чем принципиальная проблема.

Если есть время, надо экспериментировать: создали элементарный примитив в одном формате, сохранили, передали в другой формат, проверили. Затем добавили другой примитив ... и так до повторения документа в текущем виде.
(Возможно, что какие то примитивы DWG были получены откуда то еще)

P.S.

Тут у нас мимо DWG файл пробегал, сделанный в nanoCAD 11 и сохраненный в формате для AutoCAD 2013+.

Я его передать на тестирование никаким образом не могу, поскольку собственность другой организации.

Так вот, данный файл прекрасно открывается в nanoCAD 11, nanoCAD 20, AutoCAD 2018-2020 и категорически отказывается открываться в AutoCAD 2015 ! Зависает наглухо, в том числе при попытках "Восстановления файла".
Конвертация через DWGTrueView 2018, попытка передать через DXF  не помогают.

Видимо все-таки есть какая то проблема при переходе от одного формата к другому.

Ссылка на сообщение
Поделиться на другие сайты
2 минуты назад, A.Kudrjashov сказал:

 

У меня предположений нет. Надо, чтобы разработчики посмотрели исходный глючный файл и логи исправлений.
Может быть, поймут в чем принципиальная проблема.

Если есть время, надо экспериментировать: создали элементарный примитив в одном формате, сохранили, передали в другой формат, проверили. Затем добавили другой примитив ... и так до повторения документа в текущем виде.
(Возможно, что какие то примитивы DWG были получены откуда то еще)

P.S.

Тут у нас мимо DWG файл пробегал, сделанный в nanoCAD 11 и сохраненный в формате для AutoCAD 2013+.

Я его передать на тестирование никаким образом не могу, поскольку собственность другой организации.

Так вот, данный файл прекрасно открывается в nanoCAD 11, nanoCAD 20, AutoCAD 2018-2020 и категорически отказывается открываться в AutoCAD 2015 ! Зависает наглухо, в том числе при попытках "Восстановления файла".
Конвертация через DWGTrueView 2018, попытка передать через DXF  не помогают.

Видимо все-таки есть какая то проблема при переходе от одного формата к другому.

Спасибо!! Попробую поэкспериментировать.

Ссылка на сообщение
Поделиться на другие сайты

Присоединяйтесь к обсуждению

Вы можете написать сейчас и зарегистрироваться позже. Если у вас есть аккаунт, авторизуйтесь, чтобы опубликовать от имени своего аккаунта.

Гость
Ответить в этой теме...

×   Вставлено с форматированием.   Восстановить форматирование

  Разрешено использовать не более 75 эмодзи.

×   Ваша ссылка была автоматически встроена.   Отображать как обычную ссылку

×   Ваш предыдущий контент был восстановлен.   Очистить редактор

×   Вы не можете вставлять изображения напрямую. Загружайте или вставляйте изображения по ссылке.

Загрузка...
  • Расскажите друзьям

    Нравится Официальный форум компании Нанософт? Расскажите друзьям!
  • Похожий контент

    • От Vozhich
      Как отформатировать, вставленную из Exel таблицу, чтобы форматирование сохранялось при синхронизации?
    • От Тутов Илья
      Добрый день, у меня проблема.
      Создал нанокад таблицу  у себя на компьютере  в nanoCAD 10 х64 Plus, принес файл к заказчику открыли файл в nanoCAD 20 подправили что было нужно сохранили и разошлись.
      По возвращению к себе и открыв файл в nanoCAD 10 х64 Plus  слетели все таблицы, а именно на снимке 1 показана таблица созданная изначально и как она выглядела в редактируемом формате, на снимке 2 та же таблица в режиме редактирования но уже пересохраненная в nanoCAD 20. 
      Переглядел все свойства таблицы ни где не нашел ни галки с масштабом ничего.
      Как исправить данный глюк? Почему файлы редактированные в nanoCAD 20 не одекватно работают в nanoCAD 10? 


    • От dromandon
      Отдельное спасибо MCAD за данную таблицу
      на основе её логики была реализована моя =)
    • От RusInteKo
      Добрый день, столкнулись с проблемой с открытием файлов на сетевом диске. При нажатии двойным кликом ничего не происходит. В диспетчере задач запущенный процесс Нанокада висит секунд 10 и исчезает. Если скопировать файл на рабочий стол, то без проблем открывается. Но если на сетевом диске на файле нажать на правую кнопку, потом выбрать открыть с помощью, затем из списка программ выбрать Нанокад, то файл без проблем откроется.
      Собственно проблема в этом. Как сделать, что бы файлы хранящиеся на сетевом диске открывались просто двойным кликом?
       
      Примечание:
      1. Права не влияют на эту проблему, пробовали как с админ правами, так и обычного пользователя.
      2. На других компьютерах Автокад без проблем открывает файлы двойным кликом с сетевого диска.
      3. Файл изначально созданный в Нанокаде, так же не открывается на сетевом диске.
      4. При выборе открыть с помощью естественно стоит галочка открывать Нанокадом по умолчанию, заметьте если файл сохранен на родном диске, то он открывается без проблем.
      5. На компьютере не установлено других версий Нанокада или Автокада.
      6. На фото информация о продукте.
      7. Решили попробовать ваш продукт и на данный момент с ним работает один сотрудник, остальные 14 сотрудников работают с Автокадом. В течении года хотим перейти полностью на Нанокад, но будет странно если 15 наших сотрудников будут каждый раз при открытии каждого файла, из-за дня в день проделывать эту процедуру(танцевать с бубном).

×
×
  • Создать...